본문 바로가기

Network

[CCNA] Access-list (tftp 제어하기)


1. 라우터에 기본 설정과 인터페이스 설정을 한 후 EIGRP 프로토콜을 구성한다.

<R1 Router Config>

!
hostname R1
enable secret cisco
!
line console 0
 logging synchronous
line vty 0 4
 no login
 exit
!
int lo0
 ip add 172.1.0.1 255.255.255.0
 no shutdown
int e0
 ip add 172.1.1.1 255.255.255.0
 no shutdown
int s0
 ip add 192.168.1.2 255.255.255.252
 bandwidth 1024
 clock rate 1000000
 no shutdown
 exit
!
router eigrp 65000
 net 172.1.0.0
 net 192.168.1.0
 passive-interface lo0
 passive-interface e0
 no auto-summary
!


<R2 Router Config>

!
hostname R2
enable secret cisco
!
line console 0
 logging synchronous
line vty 0 4
 no login
 exit
!
int lo0
 ip add 172.2.0.1 255.255.255.0
 no shutdown
int e0
 ip add 172.2.1.1 255.255.255.0
 no shutdown
int s0
 ip add 192.168.1.1 255.255.255.252
 bandwidth 1024
 no shutdown
int s1
 ip add 192.168.2.1 255.255.255.252
 bandwidth 512
 no shutdown
 exit
!
router eigrp 65000
 net 172.2.0.0
 net 192.168.1.0
 net 192.168.2.0
 passive-interface lo0
 passive-interface e0
 no auto-summary
!

 

<R3 Router Config>

!
hostname R3
enable secret cisco
!
line console 0
 logging synchronous
line vty 0 4
 no login
 exit
!
int lo0
 ip add 172.3.0.1 255.255.255.0
 no shutdown
int e0
 ip add 172.3.1.1 255.255.255.0
 no shutdown
int s0
 ip add 192.168.2.2 255.255.255.252
 bandwidth 512
 clock rate 500000
 no shutdown
 exit
!
router eigrp 65000
 net 172.3.0.0
 net 192.168.2.0
 passive-interface lo0
 passive-interface e0
 no auto-summary
!

 


3. PC에는 LAB NIC에 IP 구성후 TFTP Server를 실행해 놓는다.

Computer       IP               SubnetMask        Gateway

PC1             172.1.1.2       255.255.255.0       172.1.1.1

PC2             172.2.1.2       255.255.255.0       172.2.1.1

PC3             172.3.1.2       255.255.255.0       172.3.1.1

 

각 IP 설정후 TFTP 서비스를 시작한다.

Solarwinds TFTP Server를 시작한다.

 

 

4. 자신의 각 컴퓨터에서 *.zip 파일을 한개 찾아서 파일 이름을 c:\에 test.zip으로 변경한다.

 

5. 변경한 test.zip 파일을 상대방 TFTP Server에 Upload를 해본다.

   c:\tftp  -i  172.2.1.2  put  c:\test.zip  test.zip

   명령을 입력해 보고 상대방 TFTP서버에 파일이 전송되고 있는지 확인한다.

 

6. 이제 Access-list를 만들어 TFTP Server에 통신을 거부해 보고 확인한다.

 

R1-Access-list 만들고 적용하기...

R1(config)#Access-list 150 deny udp 172.1.1.0 0.0.0.255 host 172.2.1.2 eq 69

R1(config)#access-list 150 permit ip any any

R1(config)#int e0

R1(config-if)#ip access-group 150 in

 

R2-Access-list 만들고 적용하기...

R2(config)#Access-list 150 deny udp 172.2.1.0 0.0.0.255 host 172.3.1.2 eq 69

R2(config)#access-list 150 permit ip any any

R2(config)#int e0

R2(config-if)#ip access-group 150 in

 

 

R3-Access-list 만들고 적용하기...

R3(config)#Access-list 150 deny udp 172.3.1.0 0.0.0.255 host 172.2.1.2 eq 69

R3(config)#access-list 150 permit ip any any

R3(config)#int e0

R3(config-if)#ip access-group 150 in

 

7. 이제 PC에서 다시 TFTP Upload를 해본다...전송실패해야 정상적으로 적용된 것이다.

 

8. 라우터에서 show ip access-list 명령을 통해 list를 확인하고 Match된 정보를 체크한다.

출처 : Tong - DionysosJH님의 CCNA통

'Network' 카테고리의 다른 글

[CCNA]L3 LAB 설정 하기  (0) 2009.09.24
[CCNA]Switch(1) LAB구성하기  (0) 2009.09.24
[CCNA]Frame-Relay  (0) 2009.09.24
[CCNA]PPP CHAP 인증방식  (0) 2009.09.24
[CCNA]Switch LAB configuration  (0) 2009.09.24
SIP Server install-Brekeke  (1) 2009.04.26
QOS 설정하기  (0) 2009.04.26
SNMP 실습하기  (0) 2009.04.26
Manual Tunnel LAB  (0) 2009.04.26
IPv6 OSPF Routing LAB  (0) 2009.04.26